Ticket #2 (new enhancement)

Opened 7 years ago

Last modified 2 years ago

Make trac-git-plugin work with trac-0.11(beta1)

Reported by: ramon Assigned to: hpj
Priority: major Component: general
Version: Keywords:
Cc:

Description

trac-git-plugin doesn't work with trac-0.11.

Main reason: trac switched from using floats to store timestamps to datetime objects. Additionally the code needs timezone objects to function properly.

I have a working patch but the plugin needs more work to get it up-to-date with 0.11. There were several changes in the revision diff viewing code. Still working on/figuring out that part.

Anyone on this side interested in getting trac-git-plugin to work with 0.11b1?

How would you like the patch ? I currently have a 0.10 and 0.11 dir in my tree ?

Attachments

0.11-development.patch (34.3 kB) - added by ramon on 02/03/08 10:12:57.
0.11-development patch

Change History

02/03/08 10:12:57 changed by ramon

  • attachment 0.11-development.patch added.

0.11-development patch

02/04/08 04:23:44 changed by kfl62

I can't see 0.11 in Browse Source

02/04/08 04:51:44 changed by ramon

If I open the patch file the first line reads:

diff --git a/0.11/COPYING b/0.11/COPYING

Followed by:

--- /dev/null
+++ b/0.11/COPYING

So I'm unsure what the problem is ?

02/04/08 07:02:52 changed by kfl62

Sorry I didn't noticed. Thx

02/04/08 07:07:23 changed by ramon

No Problems,

It still doesn't work with source browsing in my develop-env. This appears related to the following snippet from

http://trac.edgewall.org/wiki/TracDev/ApiChanges/0.11#IPropertyRenderer

trac.versioncontrol.web_ui.browser.IPropertyRenderer (0.11) 

The presentation of version control properties for files and directories can be customized to a great extent. The revision properties can be customized in a similar way.
trac.versioncontrol.web_ui.changeset.IPropertyDiffRenderer (0.11) 

Likewise, the presentation of changes for version control properties can be customized. 

Working on that, but lacking time as usual :-) Are you the author of the nanosleep version ??

02/04/08 07:35:51 changed by kfl62

No I'm not the author. I just tried few days ago to switch my trac environment to 0.11 , without luck. I can't get git-plugin working. I'm not an python developer, after about 2 hours i figured out how to avoid the timestamp exception but then I stuck in same place then you.So now I wait for a solution :). Good luck !!!

02/08/08 04:06:41 changed by hvr

...just a pointer/note, that I invested some time in the original project (their project page) with respect to 0.11 support, which you might want to try out, test and report back whether it works for you... :-)

09/13/12 09:39:00 changed by

  • milestone deleted.

Milestone 1.0 deleted